Schneller Webspace, Domain & E-Mail: |
Frage: | Suche … |
Zu "" leider nichts gefunden.
in der Schweiz (Zürich): (044) 5 08 70 34, Fax (in Deutschland) +49 30 32 70 18 91.
Skype: bitpalast
Einen Moment bitte … Ihr Browser lädt die Seite.
Symptom
Ich habe meine Website aktualisiert und bin mir ganz sicher, dass ich alle Dateien in das richtige Dokumentenstammverzeichnis hochgeladen habe. Trotzdem wird statt der neuen Seite weiterhin die vorherige Seite gezeigt.
Ursache
Es gibt mindestens drei mögliche Ursachen:
A) Es kann sein, dass der Webserver zwar die richtige neue Seite kennt, aber der Nginx Reverse Proxy, wenn Nginx Caching eingeschaltet ist, noch die alten Inhalte liefert. Nginx Caching sorgt dafür, dass statische Inhalte besonders schnell geliefert werden können, weil sie nicht bei jedem Abruf neu von der Festplatten gelesen, gerendert und vom langsameren Apache Webserver verarbeitet werden müssen. Je nach eingestelltem Caching-Zeitraum kann dies aber auch dazu führen, dass nach alte Inhalte aus dem Cache geliefert werden, obwohl die Dateien auf der Festplatte des Webservers durch Sie geändert wurden.
B) Auch Ihr Webbrowser enthält einen Cache, und auch er liefert so lange wie möglich die ihm schon bekannten Daten. Möglicherweise sehen Sie also deshalb die alten Inhalte, weil Ihr Webbrowser sie aus seinem Cache liefert anstatt die neue Version einer Datei vom Server abzurufen.
C) Falls es sich um die Index-Seite eines Verzeichnisses handelt, z.B. die Homepage Ihrer Website, ist es auch möglich, dass Sie die frühere Seite z.B. index.php und die neue index.html benannt haben. Es gibt mehrere Index-Dateitypen, die der Webserver der Reihe nach auf Vorhandensein überprüft. Wenn er mit einer Erfolg hat, liefert er die gefundene Datei aus, auch wenn es noch eine weitere in einer anderen Schreibweise gibt, die vielleicht neuer ist.
Lösung
Zu A) Warten Sie einfach eine Weile ab oder schalten Sie Nginx Caching aus. Klicken Sie dazu in der Webspace-Steuerzentrale auf das Icon „Einstellungen für Apache & nginx“. Entfernen Sie den Haken aus dem Kästchen „nginx-Caching aktivieren“ und klicken Sie danach auf „OK“.
Zu B) Drücken Sie auf Ihrem Computer die Funktionstaste „F5“ oder klicken Sie auf das „Neu laden“- bzw. „Aktualisieren“-Icon Ihres Browsers. Sie können auch über das Einstelllungen-Menü Ihres Browser zwischengespeicherte Inhalte löschen.
Zu C) Überprüfen Sie, ob Sie mehrere Dateien, die mit dem Namen „index“ beginnen, im gleichen Verzeichnis haben. Benennen Sie die Dateien um, die vom Webserver nicht mehr geliefert werden sollen, wenn Sie die Website oder ein Unterverzeichnis der Website ohne konkrete Datei abrufen. Alternativ können Sie die falschen, veralteten Dateien auch löschen.
Übersicht häufig gestellter Fragen
x0>
Weitere Dienstleistungen |
---|
Billiger Webspace unter 1 SFr/Monat
|
Preiswerter, schneller Webserver (billiger Webspace) für ausgewählte andere Länder | ||
---|---|---|
"Schneller Webspace": schneller Webserver, schneller Web Server, leistungsstarker Webserver: schneller Webserver bzw. optimiertes Hosting (auf Geschwindigkeit optimierter Webspace). Webserver für Firmen / suchmaschinenoptimierte Websites und Shops.
in der Schweiz (Zürich): (044) 5 08 70 34 • GmbH, Postfach 19 15 64, D-14005 Berlin (Deutschland)
Ihr Einkauf ist steuerfrei, da Sie von außerhalb der EU bestellen. © 2024 GmbH. Alle Rechte vorbehalten. und das Logo sind eingetragene Marken der GmbH. Für Bildnachweise siehe Impressum.